PC App Beta
  • The PC App is currently in an early beta build. Core functionality exists and we are planing to add many more features and improved functionality as time goes on. Let us know what you think of the PC App here.
  • Is it possible to change the PC App device code setting once it's established? I accidentally entered the wrong device code on initial installation. Now, clicking on that field in the settings doesn't seem to allow me to edit. Uninstall and reinstall doesn't cause the app to ask again for the code.

    (I checked the registry for things with "Active911"...no joy.)
  • I'm on Windows 10. The first time I ran and it did
    nothing except let me change settings and view personnel. I shut down and
    restarted and a bunch of alerts popped up. I could click the alert and the map
    zoomed in. No word wrap in the notes so that was tough to read. I'd back out of
    an incident and I was back to a map of Africa. No way to access alerts again.

    I waited a few hours and tried again and a boatload of alerts ringed off, then it slowed down (memory overload)? But same lack of functionality. Clicking the "alerts" option does nothing.

    1284 x 694 - 60K
  • Similar experience here on notifications and map.

    Notifications will appear for about 10 seconds. If I click on the notification I am taken to a page where I can see the details of the call, as well as, a small map inset.

    The inset is zoomed in too far to give you an idea of where the call is in the county. The inset also overlaps the information displayed on the left. To see all the details or to click unavailable you need to scroll the left side of the display to the right. I think the inset should be made smaller, and the zoom level should be a 2-5 mile view. Would be niceif the default zoom for the inset could be configured for by agency or user.

    If I do nothing, notifications will disappear about 10 seconds after popping up, and the Alerts menu choice doesn't take you anywhere at this time. If the notification flies by before you can click it, for right now, it's gone.

    Personnel and Settings seem to work.

    Personnel shows those on duty as being 5600 plus miles away. I don't have a GPS receiver hookup to the Toughbook right now, so that may have something to do with it.

    Map seems to be stuck in a world view and is inactive (can't pan or scroll)

    Very excited about the PC beta (by the way choosing about indicates alpha version) and looking forward to a fully enabled version.

  • Same experience on Windows 7. Except I don't even see alerts coming in yet, although a test one did popup for a second.
  • Excited the app is up and testing.   A few questions:

    1) Once the device code is in you cannot change it (if typed in error).  How do you reset it?

    2) When an alert comes up it appears for about 5-10 seconds then vanishes.  Once it's gone it's gone.  The "alerts" tab does not show any previous alerts.  If it did personnel, once in the unit, could click on the alert and bring the call up.  There needs to be a means to find the alert if you do not activate the call in the first 10 seconds.

    3) Can the mapping revert to the same mapping our devices connect to?  On our devices we can see the maps and preplans installed.  On the PC beta it only goes to a generic google maps application.

    Great to see it up.  Looking forward to comments on questions above.

  • OK. Just installed the Beta and am having similar issues with it.

    ALERTS function in drop down does nothing
    Global map stays darkened and does nothing. No right context menu available
    Sent a test alert and it came through the PC app but had to hit the popup in order to go to the call. Hoping the app would be similar to Webview where alerts are automatic without user intervention since it is a PC version.
    Also once the alert was closed it went back to the global map which displayed as before and cannot get back to the alerts list.
    Only menu functions that seem to work are PERSONNEL and SETTINGS under Active911 dropdown and when this open seems to be a delay in displaying them.

    Have the issue with the mileage as well. Out of all our personnel only about 5-6 are showing to be more than 6,000 miles from our area including the PC the Beta App is running on and my phone which is sitting in the same room with each other.
  • Does anyone know how to get a USB GPS to work on a laptop that did not come with GPS? I have hooked one up and it showed it installed but I don't think it is working. I am getting to the internet with Verizion MiFi. Does anyone know if they are GPS capable?
  • Same as previous commenters. Alerts will only alert if I close the program and open it back up. Confirmed by re-sending previous alerts as a test. Alerts menu option isn't functional at all. I'll add that I made a special page group for this app too.

  • Robert O, What is the core functionality that should be working? The only thing that works for me is when a call comes in it will pop up on my screen for ten seconds. It will not show up in the main window of Active911. Only one time has it shown up in the Main window of Active911. The zoom level is to close.
  • I'd like to see it work similar to webview. If a call comes in, it moves the map to the call - clicking calls on the left should take you to that call on the map (webview doesnt, but pc should..)

    Currently if a calls comes in ,it pops up on the left side, but the map just shows where ever its left. It doesnt do anything, honestly- and seems kind of ptless. 

    Many times when I click the call that comes in , it sits there w/ the loading balls just rolling.. doesn't ever get to the details of the call.

    Many times the response buttons are blank, and not loading.

    I would like to see a ticker on the top or bottom of the app for announcements, training , apparatus out of service, etc. 

    Hundreds of hydrants show no matter how zoomed I was regardless of filter added.  Trying to change hydrant filter in settings causes app to crash every time, etc. Map movement gets really laggy/choppy at times.

    Watchers (Watching..) show up on map regardless of my settings disabling this feature.

    I do not notice any live movement of the devices/apparatus. They show up and stay still it seems. I was hoping to see them move to the call, similar to webview/cellphones - but actually working right.

    Glad to see this is in beta, and getting tested finally! 


  • Hello Everyone! Hope all of you had a good Thanksgiving weekend. Obviously the app is in a very early prerelease state and we are working to bring more features and fixes to it. I want to thank you for sharing your experiences and I want to jump in and address some of them first thing.

    Currently the ability to change your device code is missing. If you need to change your device code, navigate to C:\Users\{Your User Name}\AppData\Roaming\Active911 and delete a file called active911.db3. You may need to enable hidden folders in order to navigate to this directory.

    In this beta, all maps are static and will not be interactive. I believe that when we update the program to support interactive maps, most of the mapping issues will be resolved. This should also fix the problem where the map is zoomed in too far once viewing an alert.

    Many of you have reported that alerts do not show up in the alert list after being received. If I am understanding correctly, closing the app and reopening will then display the alerts. We will address this issue in the next update.

    Since most PC's don't always have a GPS built in, the position reporting can be very inaccurate. This also may be causing the issue with some of you seeing a map of Africa or a world view instead of your local area at some times. The app is designed to ignore position functionality if the location accuracy is not within 10 meters, but it seems like this is not working for some of you. I will have to check on what is going on there.

    Currently the intended core features that are supported are:

    - Receiving alerts as they come in and being prompted with a notification
    - Viewing a list of previous alerts
    - Viewing your agency's personnel with response status and assignment information
    - Viewing an individual alert's information
    - Responding to an alert
    - Basic settings

    I want to thank you all again for your feedback, and I will try and keep you updated as we make progress and there are updates available.
  • Many of you have reported that alerts do not show up in the alert list after being received. If I am understanding correctly, closing the app and reopening will then display the alerts. We will address this issue in the next update.

    When you go to the Active911 tab and click on alerts nothing show up. Closing the app and reopening and nothing still show up for alerts.

    After running having the up and running for two days the alerts stop coming in. I have to close the app and reopen it to get alerts to start coming in again
  • I too thought the alerts stopped, but on closer inspection that is not the case for me.

    It appears that they stop, because when the come in, they are in their little notification popup window for 10 seconds, then if you haven't clicked on it,, it is gone. Since the Alerts menu choice doesn't work, there is no way to get to the notification that just flew by.

    When you close Active911 and then open it again after several new alerts were sent from dispatch, it appears that the alerts are now working as there are so many of them that you can actually watch them appear on the screen and then fade away.

    But from what I can tell, if you are lucky enough to be watching the screen when an alert comes in on say your phone you should see a notification on the PC app.

    Even though I can apparently receive notifications, I never see anything pop up when I send a test message. Not sure why?

    For now, I have stopped testing as the App is not a working version, it is more proof of concept, since we can see the promise of tomorrow, but can't yet use the app in a meaningful way. I look forward to the news that a working beta has been released.

  • Same here when receiving the alert. If you click it immediately you it will work, if not it is gone forever.
  • same issues app seams to freeze unexpectedly then if I open it and it was shut off ill get a bunch of alerts all at once
  • Is there a way to get on the Beta list?
    Micky A. Blain
    Prosper Fire Department
  • Here is the link to the Beta Wiki Page, if that doesn't work you may have to copy and past the following into your browser.

    You can also Google, Active911 beta
  • How can I download the beta version?
  • The only part of the Win10 PC version that works for me is to see the dept name and the list of personnel.  I get the grayed out world map and receive no alerts, not even fleetingly and not even those sent from my primary user account as a test msg.
    The one possible anomaly about my current set up is that I have no access to active GPS feed on the host computer.

    Are there fixes in the works that would allow a new download/install?
  • We are working on fixes and new features currently. We will let you know once it is ready for trial.
  • I downloaded the PC App onto  a brand new Lenovo ideacentre Stick 3000, that is running Windows 10. It installed without any problems. After opening the program, it seems to just stall, with the green line running across the screen. It has never given me the option to even put in the registration code. I have it running on other Windows 10 computers and have not experienced this issue.

    Active911 Support-any ideas or suggestions?

  • Rob, try navigating to C:\Users\{Your User Name}\AppData\Roaming\Active911 and delete a file called active911.db3. You may need to enable hidden folders in order to navigate to this directory.

    I'm not sure why your machine would be doing this, but if these steps fix this, then it will give me insight into what is going wrong.

  • Robert-I have enabled hidden folders and this file remains missing. I have uninstalled, re-downloaded the program and tried to reinstall it. Same results. The appdata folder exists-but no files.
  • Robert O---
    I installed the PC program on another Windows 10 computer. It too did the same action-green line continues to run across the screen. It did however have the db3 file in the app folder. I deleted and tried again----No Change. Still green line running across screen. I even tried uninstalling and reinstalling with and without the db3 file-No Luck!

  • I have a suggestion which will not be a permanent fix, but may shed light on what is going on.

    Try right clicking on the app and selecting run as administrator. It may be that the app does not have permission to write it's storage files to the location in the app folder.
  • Robert O.
    Tried your last suggestion-No changes. I also have tried to run in compatibility mode all the way back to Windows XP-No luck
  • I have not seen an alert yet. I installed the PC App about a month ago and all the settings seem correct but still no alert.
  • This new update (3-16-16) - is a huge improvement.

    The only thing I can't do so far is the Personnel button doesn't bring anyone up - and the buttons need to be longer to fit our response choices. (they get cut off)

    I also noticed I see a bunch of people on the map for some reason w/ old responses to old calls, just randomly placed around the map)

    Besides that, so far so good- will keep an eye on things.
  • Glad you are liking the progress! I just want to point out that the most recent release you are referring to is the Tablet version which will run on Windows 8 and 10, but is optimized for tablet use. The Desktop version is closing in on some of the same level of functionality and should be released in the next week or two.
  • I am a current beta tester where do I download the new version

  • The current desktop beta can be found under the Windows Desktop heading at http://wiki.active911.com/wiki/index.php/Beta_Testing

    The current tablet beta can be found in the windows store, but only if you have a voucher from support@active911.com

    If you want to try the tablet version, but have not received this voucher, please contact support.
  • Just released an update to the PC Beta! It can be found under the Windows Desktop heading at http://wiki.active911.com/wiki/index.php/Beta_Testing

    This version includes:

    • Interactive Map
    • Displays all devices on map
    • Displays all location markers on map
    • Displays current position on map
    • Displays alert location
    • Displays routing to an alert location
    • View marker location's pre-plans and other resources
    • Respond to alerts
    • View responses to an alert
    • Prompts to update when updates are available
  • We still cannot get a default location to show up on the map for our firehouse. Tried setting up the default location in control panel (Location and Sensors:Default Location) but this does not seem to locate our street address nor can we enter in our LAT/LON. We are using WIN 7 Enterprise OS.

    Our goal is to run PC APP on a large monitor, without a GPS or GPS emulator on the PC, and display routing information to the scene from the firehouse. We tried the third party GPSgate software - and that did not work either.

    Any suggestions?
  • All of my alert markers are centered on the map, and I can´t get any routing. The alert-history popped in when I I installed the application but I can´t recieve any new ones..  
  • Robert O

    my name is ashton foster I'm the same problem as Rob K is having. I have try to stuff to told Rob K but still no luck I have a Panasonic Toughbook CF-31 running windows 7 pro what is the next step? I have uninstalled then reinstalled.
  • I also have Rob K and Ashton F's problem with nothing but a moving green line.  I reported this by email to the beta address.  I've tried it on two Dell Latitude's running with admin privileges on Win10 Pro using downloads of March 30th version.  Any help possible?
  • Hi everyone!

    I want to thank everyone for the feedback we have received in both this forum and via the windows beta email. All of the feedback has been very helpful and I appreciate it. 

    I also want to update on the spinning green loading bar that many of you are experiencing during start up. We are currently working on diagnosing the cause of the problem. We had addressed the issue in the most recent beta, but obviously the problem was not resolved. I'll reach out to you if I need any more information to help get to the bottom of it if I need to.

    I'll keep you updated as we move forward.
  • Few Questions about the Windows 10 Universal App. 

    1.) When a call is received and the app is open you'll get the toast notification but the call will not show up in the actual screen.

    2.) When it comes to the NAV, the blue dot that indicates the device,  is it supposed to move with the device? I know with the default map app this functionality works.  (It seems like a refresh issue)

  • I like the progress on the Windows application.  On Win7-64, changing the compatiblity settings to "run as administrator" allows me to see all of the "responders".  this is handy.  View options in the menu are still grayed out and unavailable (guessing that's a placeholder).  I'd like to be able to toggle personnel on and off (possibly by pagegroups) and see all of the active incidents at once or multi-select from the list.  I still cant commit alarms from the application, but that is understandable since it is in beta.

    Finally, for us wildland folks, the aerial photo is a huge Situational Awareness tool.  if you could have that as an option, that would be great.
  • Robert4049, I think your comments may be in regards to the tablet version of the app. It sounds like there may be a bug preventing the call from showing up on the screen when you see a toast notification. I'll check on this. As far as the NAV, this is determined based on data received from your device. If the dot does not seem accurate and does not move around, you may not actually have a GPS in your device.

    William G. It's nice to hear your feedback and I have some good news for you. We have a build in house that allows you to commit calls, use the options in the view menu, and see the aerial layer on the map.

    There has been a lot of work done on the app and I think we will have a new version released this week. I'll have more details soon!
  • New release today? 
  • Sorry it took so long. Just released the update. It seems that this version may have some hiccups when updating. If when you update the app will not start, uninstall the app and then download the app again from the wiki page and install. http://wiki.active911.com/wiki/index.php/Beta_Testing

    If the app has trouble starting for the first time, close and reopen it.

    Other than these updating hiccups, this release should be more stable than previous builds. It should also start up much smoother from now on. New features in this build include:

    - Ability to create/edit alerts
    - Personnel view is now enabled and will display (No interaction is enabled yet)
    - There is a new menu that appears when right clicking on the map which includes the following:
         - Displays coordinates where you clicked
         - Create / edit alert functionality
         - Marker feature is currently disabled
         - Working distance ruler
         - Ability to choose different map types including aerial
         - And the ability to remove the target from the location you right clicked on

    A few notes:
    The settings didn't get any features added to it yet. This should come soon.
    Also, you may have had multiple windows open prompting you to download the update. This will not happen again with future updates.

    I will be putting a blog post up on blog.active911.com soon that will outline some of these features and changes.

    I look forward to hearing about your experiences with this new build!
  • App is looking good.

    A couple of things I noticed not sure if it's just my pc or not

    1. Can't find how to create Alert
    2. Distance ruler does not allow me to draw a line on map nor does the distance pop screen show any measurement after dragging across the screen
    3. Now unable to drag the map screen

  • Glad to hear some feedback!

    In response to your points Jeff:
    1. You can create an alert by clicking on Active911 in the menu bar at the top, then selecting create alert. You can also right click on the map and select Create Alert from the menu that appears.

    2. I'll have to look into any reason why the ruler does not display when you are in ruler mode.

    3. If you cannot drag the map anymore, you may be in Ruler Mode. Try right clicking on the map and selecting End Ruler Mode.

    If anyone can comment on how the update process went for them I would be appreciative. Did it go well? Did the app hang at all? Did you need to uninstall and reinstall the app?

    Thanks everyone!
  • After some additional testing:

    1. The send alerts is greyed out

    2. It appears that the map drag and the ruler measure only work with a key board and not directly with my touch screen as before

    3. Ruler is in mile distance setting and not feet

    Thank you
  • For me the ruler works fine after I figured out that once you enter ruler mode you have to click and drag to create a line. You will definitely want to include that in the directions for end users. 

    Creating an alert is greyed out for me. I checked the device settings and there is no where to allow the PC to create alerts. I am assuming this is what you are referring to for the settings not getting updates yet.
    Chief Hardeeville Fire Department
  • Thanks for the feedback. I just put up a post outlining the newest features at http://blog.active911.com
  • The one issue I see right now is not being able to zoom out on the map. (I could be missing something here)
  • installed, no place to enter device code- I click on the " Active 911" upper left next to "view" and "Help"- then says not responding....
  • Tom G. If you are far enough along into the app that the Active911 button appears in the upper left, then the app believes that you already have a device code entered. I'm thinking this may be a problem updating the app. Did you install this version as an update to a previous version? Does forcing the app to close and reopening it change the behavior?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion