PC App Timeout
  • Hey all - 

    I am running v1.1.3.4 of the PC App. I am seeing an issue arise where the app will not reconnect after a loss of network connectivity. I am assuming this is what is happening but I cannot seem to locate a connectivity status similar to the web view. Under the Active911 menu at the top, there is a status showing connected where you enter your credentials, but it is not the case as new alerts do not come in. 

    I can provide any additional troubleshooting steps as needed, just curious if anyone else is seeing this problem as well. 
    Zach Marvin
    Union, OH Fire Dept
  • I guess I should add, this is running on Windows 10 64-bit.
    Zach Marvin
    Union, OH Fire Dept
  • Ever since the latest version (1.1.3.4) - of the PC Desktop version of A911 - it keeps crashing randomly - sometimes with out any calls coming in, other times when a call should come in. Other times it just stops receiving alerts w/out a notice of it crashing. I have sent error logs to A911 staff, and am hoping the newer version coming out will resolve this. 

    Is there a way to go back to the prior version and turn off update popup notifications? The previous version was flawless for us. 

    About how far are we from seeing that update available for public? I heard they are testing an update soon -- but we need a fix sooner than later. This crashing is happening on multiple systems, operating systems (Windows 10, Windows 7,etc) multiple users.
  • We have a new Windows release in beta testing now.  If either of you would like to install it to see if it resolves your problems the link can be found here.
  • Will do - will let you know. Ty!
  • Installed latest BETA 1.1.6 around 9:30am EST, crashed at 2:44pm EST) -- 

    (crashed at random, no call came in at 2:44pm EST)

    Faulting application name: WindowsDesktop.exe, version: 1.1.6.0, time stamp: 0x58fe936d
    Faulting module name: KERNELBASE.dll, version: 10.0.14393.1066, time stamp: 0x58d9f07f
    Exception code: 0xe0434352
    Fault offset: 0x000da932
    Faulting process id: 0x764
    Faulting application start time: 0x01d2c7ffe6e9445c
    Faulting application path: C:\Program Files (x86)\Active911\Active911\WindowsDesktop.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: 08f9726f-c7ee-4055-97ad-b79077613fd4
    Faulting package full name: 
    Faulting package-relative application ID: 

    I have attached a more verbose debug from the error under .NET framework.
    a911-beta-161-error1.JPG
    1863 x 895 - 417K
  • Having the same issues with the new beta installed it's actually been crashing my operating system (win 7)
  • Bump for Robert O (above is the debug of the error I am getting)
  • Adarm R., Have you seen this error very frequently? Does it happen on all new calls or just some? Does it happen when there is not a new call?

    The error is associated with a library we are using. We have an update for that library coming in the next release, but I am not certain if that will resolve the problem yet.
  • Happens randomly, not necessarily on a call. Sounds good regarding library update - if you get it into a beta build, and want me to test it - just let me know.
  • We're having the same issues as Adam R. We're also running v1.1.3.4 on Windows 10 64-bit. The app won't reconnect after losing internet and it crashes at random times. Sometimes it crashes with a call, sometimes minutes after starting the app, and yet other times it will run for several  hours before crashing. There was a link I found for a beta version you guys were working on so I downloaded it at our House 2 and it has been doing the same thing.

    A separate issue I have noticed is with the call history on v1.1.3.4; history will be set for 1 day, but if we open the app after several days all of the calls will be in the side bar. If we go into settings, click apply (since it's already set for 1 day), and close/reopen the app the call history will then reflect 1 day. Not a big issue but worth noting for your next update.
  • Just pushed an update to the beta version. Please give it a try and let me know if there has been an improvement.
  • I will try this build today, and see if we get any better results. Thank you Robert.
  • 3 calls so far, so far so good- no crash - keeping an eye on it - its random after all.

    I did notice that there is a strange issue w/ the icons now - The hydrants are huge and the call placement banner/icon is so tiny no one could read it if they tried.

    If I resize the icons (marker size) it makes the hydrant smaller, but the call taker banner icon super tiny- etc.(shown below) --  Can we have the call taker banner separate to the marker icon size , basically independent sliders that control markers, and then the call placement banner?


    bigicons small call icon.JPG
    1194 x 730 - 164K
  • Crashed again- unfortunately. (using newest beta build)
    a911-crash.JPG
    1110 x 738 - 168K
  • Error attached from Application Logs via Event Viewer:

    Faulting application name: WindowsDesktop.exe, version: 1.1.6.2, time stamp: 0x593b2dd9
    Faulting module name: KERNELBASE.dll, version: 10.0.14393.1358, time stamp: 0x59327ae2
    Exception code: 0xe0434352
    Fault offset: 0x000da9f2
    Faulting process id: 0x1ad8
    Faulting application start time: 0x01d2e9c8c0853296
    Faulting application path: C:\Program Files (x86)\Active911\Active911\WindowsDesktop.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: 1c74649a-bb6f-4e79-a31a-c93e2d769073
    Faulting package full name: 



    net-framework-error-a911.JPG
    904 x 647 - 113K
  • Thanks for the screenshots and detail Adam! That helps me a lot in resolving the issue. Since the crashing issue is occuring on the production version of the app, I don't think it is going to hold up the release of this beta to production, but we are going to get it fixed in the next version.

    Can you navigate to C:\Users\{YOUR USER NAME}\AppData\Roaming\Active911\Datastore
    There should be a file in that folder called storage.a91
    Please send that file to windowsbeta@active911.com so I can use it do further diagnose the issue.

    Thank You!
  • Sent this morning. Thank you Robert.
  • Adam, I didn't receive an email from you. Are you sure the email was sent to windowsbeta@active911.com? 
  • I am having this issue as well. Running 1.1.6.0 the pc-s in the trucks run fine, then the program just stops, and a window comes up saying it stopped. We have to close it, then re-open and it seems to work fine for a while.
    I don't see any real reason on pattern in it.

    Mike
  • We seem to be experiencing the same issue.  Not sure why Active 911 shuts down, daily.

    JW
  • I believe we have a fix for this, but it won't be available until we move the PC app to external beta. That's when we will know for sure if the solution worked. I'll post in here when the beta version is available.