PC App Beta
  • I am having problems with loading the app. I have never been able to run the app since the update, it just locks up with "Not Responding". using Windows 10 on a Toshiba laptop.
    Active911_App.jpg
    1291 x 692 - 40K
  • @Robert O

    Hey,

    So we've used both the Modern App and the Standard Win32 app. The Win32 app was tracking the laptop but after it rebooted it stopped. Also, the normal maps app can detect the device and where it is. When it comes to the Win32 app the only suggestion i have is that the map moves when the dot does. Also could it be made touch friendly? I know this is the purpose of the Modern App but it seems that it's not progressing as quick as the Win32. 
  • @Jason A
    Did you install the app by being prompted to update it or did you download the installer for the latest version from our website? Try uninstalling the app and downloading the latest installer from our website and report back: http://wiki.active911.com/mediawiki-1.22.2/images/f/f1/Active911_Installer.msi

    Are you saying that the laptop stopped reporting its position to other devices on your account or that the laptop's position stopped updating on the map inside the PC app? This is something that I am going to need to look into. Also, updating the app to keep the map centered on the device's current position is something that we are planning on implementing in all of the platforms we support. I will try to add this to the PC app soon.
    As you said, the Modern App is intended to be the best experience for touch, but I don't want the PC app to be left out when it comes to touch interaction. The last update broke touch interactions on the map, but I plan to push a new update very soon which will re-enable touch. The PC app needs to remain as mouse and keyboard friendly as possible as a priority, but if you have any suggestions on where it could be more touch friendly, please let me know.
  • Just want to update everyone that beta version 4 just went live. You shouldn't notice any major changes, it is mostly minor optimizations and bug fixes. Touch interaction with the map has been fixed in this version.

    I do apologize, I am still trying to work out issues with the update process. It may not work correctly and you will need to uninstall the app and download it from out site and reinstall it. Here is the download link: http://wiki.active911.com/mediawiki-1.22.2/images/f/f1/Active911_Installer.msi
  • Not sure what happen just uninstalled previous beta version downloaded new version 4 and now the start up screen stays on "preparing devices" and will not complete the startup
  • @Robert O -



     



    I downloaded the installer
    and installed it that way. I removed the program prior to installing the new
    version. After reading your reply, I removed the app again and used the new
    link you posted with no luck either. I also went and installed Microsoft .NET Framework 4.6.1 to ensure I had
    the latest version. Still no luck, it sticks on not responding.



     

  • @Robert O

    As far as I'm aware it only stopped updating the map that was presented to the user. I was riding shotgun playing with the map in the chief's vehicle. When I noticed it stopped updating the dot I switched it back to the modern app (didn't work) reinstalled the Win32 app and still no go. I didn't try clearing the app data folder or anything to that nature. Just as an FYI We're running Windows 10 Enterprise (Latest Build and Updates). If you want I can try the latest build of the Win32 app and see what happens? Also when it comes to the touch suggestions i'm not to sure what's been already implemented so i'd have to wait and get my hands on it and see where you're at. I'm happy with the Win32 interface so far in regards to design. 

    Also as an FYI we have 2 devices in testing a Windows 10 Laptop and a Microsoft Surface 3 (not pro) all with built in LTE. We had to abandon the whole Windows App concept for the Surface 3 because it's on the engine and is used daily to where as the 10 laptop in the Chief's truck and is not used as often. What we wound up doing is running android virtualized as a custom shell and we've been happy so far and loading the apps on there. The reason being is because we ran into some issues with the Windows Modern app where if the app was open the call would not show up but we would get the toast notification which made it pretty much useless which is why I'm exploring the Win32 app. 
  • I have uninstalled the old version, downloaded the newly pointed to installer, installed the latest, but am still left with a famous moving green bar on the Active911 splash screen.  I can get no further.  Was this problem resolved and I missed it?  Getting frustrated.  This is the third version that I have installed on three different win10 computers and I have asofyet to see a single map or alert.
  • New update went live today. I focused on resolving the botched update process and fixing start up issues.

    Everyone who had problems with the last update, I believe that the kinks have been worked out of the update process. This should be the last time that you will need to uninstall the app and download it from our website again. I think that some of the work on fixing the update process may have caused some of the extra problems that some of you had experienced this time. This is resolved in this update.


    You may have a broken database file from a previous build. Enable hidden folder and navigate to C:\Users\{Your Name}\AppData\Roaming\Active911\ and delete the active911.db3 file. Let me know if this clears up the problem please.

    Thanks for clarifying the position situation. I've made a change in the version of the app that went live today which I think will fix the position problem. I spoke with the developer working on the modern app and he said that some of your problems should be resolved, so if you could give it another try and let us know how it went, we would appreciate it.
  • One more thing I thought I would let everyone know. If you click Overview under the View menu five times in five seconds, you will unlock a hidden debug menu. This will let you open a log window that outputs information on how the app is running. If anything is working incorrectly, this log could be very useful for me when fixing the issue.

    Thanks!
  • Still no joy.

    I have hidden extensions/files turned on.  There is nothing but an empty Resources directory in the path you indicated and in fact a C: search finds no such file anywhere on disk.  Seems to not be a .db3 file problem.

    I just installed on another Win10 laptop and I for the first time am seeing maps and alert lists.  However, this is a borrowed computer -- just to prove a point -- and does not remove the problem from my two targeted machines.

    Is there perhaps another bad Active911 file from the prior installs?
  • New build still not working for me either.
  • App is taking shape

    appears to be working for me on win7 32bit. Blue location dot still lagging behind unit location. Unit ID Tag does not more properly with unit from location to location. Map touch screen working ok, however when you right click and select measure, you have to use mouse to draw distance line same with when you use touch screen to zoom in to see map markers, you have to use mouse to open map marker data
  • I too have the same result-Just the initial load-up screen and the green bar.
  • @Robert O

    I'll just second what Jeff D. said; aside from the map maker. It's still not updating for us.
    What's odd to me is that when i first used the application it worked but after closing it and re-opening it the updating stopped. Also, if i close the app and re-open it the marker will update without hesitation. This is the same for Win32 and Modern. 


  • Hello


    Is there a way to make it so you don't have to zoom far in for map markers. also I know not related to this app but I wish you can tie markers to addresses aong with gps so you can have keybox and info like that come up upon dispatch. also is there a way to use the new google 3d map.


    Thanks

  • i am having trouble with my app the calls dont always come through. a call will come but not show up in app but if a close out the app and open it up it shows up in the list.
  • Robert O.:  How about adding a timeout to the initial splash screen (with its moving green bar) that puts up a brief text / status explaining what it is waiting for?  There seems to be no progress in resolving the problem and w/o additional hints some/many beta testers are totally lost.
  • @Mark and @Jason A.
    Has the app ever asked you to input a device code? I think I'm beginning to understand what is going on on your machines.

    @Jeff D. and @Rob K.
    I have been testing on a tablet with a touch screen, but I do most of the work on an actual desktop without a touchscreen. So I didn't notice that the ruler and map markers only worked with a mouse. I've got that fixed and you will see it in the next build. Thanks for pointing that out to me.

    Should release a new update in the next couple of days. Going to focus entirely on fixing bugs and the loading problem. I am also going to start giving GPS a lot of attention since it sounds like it is not working like it should.
  • I downloaded the update today and it gets stuck at "Preparing Devices." I uninstalled the old version, downloaded/installed the new version and still same issue. 
    Chief Hardeeville Fire Department
  • Robert O,

    I don't believe the Active911 Windows applicaton (vs app) will require the use of a third party location service wrapper-driver for Windows 10, e.g. turboirc GPSDirect, when using external USB connected BU-353S4 on Toughbook CF-19. But, I wanted to confirm.

    We are currently running Win 7, but are seriously considering taking advantage of MS free Win 10 upgrade.

    We tested original Windows application beta but couldn't get far enough along to test external GPS.  We do have the prolific driver loaded to redirect to COM port.

    From the thread it looks like you have made substantial progress since the New Year, but I won't be in position to resume beta testing for a few more weeks.

    So in the absence of any current beta testing by us, I would appreciate any technical insights you can provide that would aid us in our plan to use Active911 on our Toughbooks in in apparatus--via email or on this thread.

    Thanks,
    Garry
  • Robert O:  During initial beta version Win10 app did request device code.  However, that version was replaced after uninstall with later versions.  With both subsequent versions all I get is the famous moving green bar.  No request for anything and no hidden .dbs files.  Multiple, virtually identical machines in same state wrt A911.
  • @Garry H.
    Using a third party service like turboirc or GPSDirect will still work fine if you choose to use them. In the next PC update which I plan to release tomorrow, GPS functionality is built in. In the case of external GPS devices, you will still need to install the driver, but the PC App will communicate directly with the GPS unit from there. I have tested a Toughbook CF-30 with built in GPS and I have tested a BU-353S4 on Windows 10 and both of these devices work great.

    I believe that I have gotten to the bottom of the problem affecting your installs. I have done a lot of work to try and reproduce and fix the issue and I think that the next update will resolve your problem. Like I said above, I plan to push this update live tomorrow.
  • New beta release just went live today. This version includes improvements to the startup process which should resolve any startup issues anyone is having. Here is a full list of the changes since the last update:

    - Improved app startup process
    - Added ability to communicate with GPS devices (internal and usb)
    - Zoom in / out buttons with hotkeys
    - Nearest locations
    - Create location (device must be given edit locations capability)
    - Settings options have been added
       - Themes (Dark and Light mode)
       - Default Map Style (Aerial / Roads)
       - Default location for devices without GPS
       - Automatic route to call option
       - Map marker density
       - Map marker size
       - Ringtones per agency
       - Duty status
       - Assignment
       - Pagegroups
  • Where can I locate the link to the new update for the PC Beta ?
  • Robert O.....The new release is a winner. I had no problems loading and the program is up and running. 

    One question: I still have not been able to have it show a response route for any calls. Is there something I am missing?

    Thanks
    Rob
  • App Is fantastic !! Two things

    1. It shows the alert twice in the alerts list box
    2. I keep setting the map desity to suburban and it keeps defaulting it to urban
  • This is the best Beta release so far - so good improvements.

    Big things: 

    People who responded in the past are showing on the map / and markered. They shouldn't show on the map at all unless its a response currently.

    We also have WATCHING / WATCHERS turned off on the website's settings for showing on our map - yet it still shows these people on the map/markered/wandering w/ the Beta releases of A911 (PC app and Tablet app, I believe).

    When I initially started the program up , it asked for the Device Code (new install of this beta release) I typed it in and submitted, and the green bar went for 5 mins animating - i finally closed the app down, and restarted it - and it opened 50/50 calls etc, green line animating and opened without issue w/ all the previous call data on the left side frame. 

    When a call comes in, it needs to center to that call on the map. (same as Webview does now) - if not auto, at least an option to allow it in settings?

    I have also noticed duplicates of the same person/device and/or marker (ie WATCHING or RESPOND, OR AVAIL - right next to the other marker - so 2 exact markers of the same person using that device side by side -- obviously a bug as well.

    When the notification box comes up of a call that just came in - on the bottom right of the screen - clicking it does nothing, yet it highlights like it should do something when you mouseover it.. (should it?)

    Under the new "Mapping" tab , changing density from Urban to Rural for example will not save. It will keep reverting to its settings. Also Changing the size of markers, does the same thing - it will revert back when you close settings. The fact there is no Apply or Save button - maybe that's why? 

    Looking good moving forward with each Beta release - Thank you! 
  • Looks really good so far.  I have noticed that when personnel pop up on the map, they never disappear.  On the iPhone, personnel who are watching a call disappear something like 5 minutes after they close the app.  The personnel need to eventually disappear, to avoid clutter on the map.

    When a new call comes in, a marker pops up with the location of the call, but if the location of the call is off the screen, you have to manually zoom out in order to find it.  I'd prefer to either re-center the map with the location of the call, or auto zoom out so that your current location and the location of the call are visible on the screen.

    I noticed that there's no OK button on the settings screen.  Adding OK and Cancel buttons would help avoid any confusion as to whether clicking the X on that window saves or discards changes.

    I envision having the PC app running on a big screen in our station, and for that I can think of 2 features that would be really useful:
    1. Option to have the call details display in a second column to the right of the column with the incident list.  Frequently we get 2 or 3 calls in rapid succession, so keeping the incident list visible while also showing details on the most recent one would be helpful for us.
    2. Option to show map markers for the most recent calls (most recent N calls, or calls within the last ## minutes, which ever is easier to code), not just when a call is selected.  This would help our supervisors visualize where the active calls are.  Even better if there could be an indicator of the age of the call, e.g. replace or overlay the shield on the map marker with the number of minutes since the call was received.
    Thanks!
  • Thanks again for all of the feedback. It has been immensely helpful! As we work towards the next beta release, my focus areas will be on fixing the following bugs:

    - Marker density setting is not persistant
    - Devices are not disappearing after time
    - Devices are showing up more than once
    - Alerts are showing up twice
    - Map should center on new alerts as they come in
    - Clicking on the notification of a new call should bring the app into focus
    - Settings need an apply button to prevent confusion

    If I am missing anything, please let me know.

    Thanks to Alex B. and all others who have suggested feature ideas. As the app progresses I am envisioning it needing to provide more ability to customize the display. All input on where and how everyone intends or would like to use the app would be appreciated.

    @Rob K.
    Do you have automatic routing enabled in the settings? Does the app report a location for you? The only reason I can think of as to why you would not be getting routing is that the app does not know where to route from.
  • Thanks for the updates Robert. I am looking forward to the new builds. 

    Great job moving forward!



  • Robert, the PC App looks great!

    I noticed that on the personnel flags, the responses don't consistently update and some of our flags are not populating with the call in which they responded to.

    I am also trying to figure out how to get the blue dot to update more consistently without a lag on a CF-30 running Windows 7.
  • We now have GPS! However there seems to be a significant delay and accuracy isn't all that great. I launched the native Windows Map app and it's dead on.... I'm not sure what the difference is? I was looking at the log and it's got a 17 meter +/-. Also, the Modern Windows App still doesn't recognize GPS what so ever. 
  • New update went live today. This one contained all of the bug fixes from earlier.
    If there are not any problems with this build, it will most likely be the initial version released outside of the beta program.

    Are your devices using internal or external GPS?
  • We have a Latitude with Embedded LTE and GPS. I'd have to get the exact model number of the WAN card in it to get you the GPS info. 

    Here's the methodology I used:

    I pulled up the Win32 app and pulled up the log by using the overview button 5 times. Noticed it was a reporting and refreshing the location. I drove around and saw that the location wasn't all that great. So I thought it may be the laptop (Windows 10, Dell Latitude) so i pulled up the generic map app for windows and started driving around and saw that it's location was far more accurate. I then snapped each app to one side of the screen and compared the two as i was driving and it was night and day. Regardless, I still thank you for getting the GPS working, it's a great stride forward. 
  • Looking good although I think there has been a regression with the notification window.  It displayed correct information in the previous build, but on the last call I got today, instead of the call information, what popped up was clearly placeholder text:  "NotificationWindow 123 NotificationText" or something like that - unfortunately I didn't get a screenshot.

    I'm still seeing text flowing off the device markers when a status is displayed, for example "watch: PUBLIC SERVICE CALL".

    There is a new bug though, the list of responses (directly below the response buttons and above Details) now defaults to expanded.  I'm worried that if we get 20-30 people responding it could push the important call details off the screen.  

    I've also noticed that when zooming the map to a new alert, the space covered up by the list of alerts is not taken into account, and either your current location or the location of the incident could end up behind the alert list/details.  This section is somewhat transparent (not the list of responding devices, though!) so it can be very hard to see the map.  Better behavior would be to make sure that the incident location and your location are both kept on the part of the map that isn't obscured by the incident list.  Also, it would be nice to make sure that the entire route fits on the screen, because sometimes the best route to the call is not a straight line (for example, a lot of calls south of our station are accessed by first driving north to get to a major roadway). 
  • I just updated to the latest beta version and I am still having problems with:

    1. The devices are staying on the map.
    2.  When you click on the call, the map zooms out to the entire world.

    Would also like to see an option to mute or have no alert sound since we use this in our dispatch center and to have calls clear after an hour, not just 1 day.  Otherwise looking good!  
  • @Robert O, I am using the internal GPS on the CF30... It does look like its reporting the position but not updating on the map.
  • I am testing out the app and I am having the same problems. the alerts never show up or alert. if I close out the app and open it up the past alerts then show up. also when you click on a alert it does not center itself on that area.
  • @Robert O, I see in the debugging that the Lat/Lon is being constantly updated but the blue AVL mark on the screen doesn't updates to reflect the position change. 
    Also, is there going to be a way to show the PC apps on the map all the time if they are reporting a position like a typical AVL? We have CF-30's in our trucks and it would be nice to see them on the map whether they are on a call or not.
  • I know this is scope creep, but... would it be possible to add a custom action to be taken when an alert is received?  This would hopefully just require a couple lines of code to call System.Diagnostics.Process.Start() with a command line specified in the settings windows, and it would open up nearly unlimited possibilities for those of us who wish to create new functionality driven by Active911.  My immediate use case would be to launch a turnout timer, but I see a lot of potential uses such as sending the alert text to an LED sign board, controlling various IoT devices, etc.
  • Downloaded the app multiple times, presents me with the screen to add the device code, but the Next button is greyed out and won't let me proceed. Tried running as administrator as well with no success.
    Dell Latitude E6530 / 8 GB RAM / i5 processor / Win7 64-bt / current on .Net / Java / etc.
  • Sorry for some of the radio silence everyone. I've been out of the office for the last week.
    There has been one new release that should have fixed the notification text issue. I've also returned the list of devices in the call detail screen to be collapsed by default. An option in the settings to have the expanded or collapsed by default will come later. And I have attempted to improve the positioning and zoom level of the map when a new alert comes in.

    There seems to be two problems that everyone is having at the moment which are alerts not coming in while the app is open and position not updating smoothly. To address the first issue, the app relies on the XMPP protocol in order to receive alerts and information from other devices while it is running. XMPP uses port 5222 so it is important that your firewall and network allows the app access to port 5222. If those of you experiencing this issue can check whether port 5222 is open and report back, that would be very helpful.

    My thoughts on the position not updating smoothly are that we reject any positions we receive from a gps if the accuracy is not within 20 meters. If the accuracy is not within 20 meters then the position is still logged in the super secret logging window, but the app itself will not do anything with it. This may be that the custom code we have written to read external GPS devices needs some reworking to more accurately calculate GPS position. I will look into this.

    Thanks for the sharing the idea to run a custom action when an alert is received. I think it is a great idea! I'll look into a way to expose a hook for this, but at this point I cannot guarantee anything like that.

    The next button issue will be fixed in an update soon. If you are still experiencing the problem, just press the enter button once you have entered a device code.

    In closing, we quitely updated the app to a release version on June 1st. Today we are planning on making an announcement of its official public release. We think that it is stable enough that it can be used while we continue to add new features and improvements.
  • Robert I have check the port using canyouseeme.org and it says that port is blocked. but I am not blocking any out going traffic that I am aware of and my firewall is turned off on my pc. not sure if I have to do anything else I have been testing this on my personal pc at home to help remove the probability of the corperate networks. and the alerts do not auto center t actually zooms out the map when I click on the alert.
  • @Mathew A.
    I don't think canyouseeme.org is adaquet to verify if the port is blocked by a network firewall on your machine.
    If you follow the instructions here: https://kb.acronis.com/content/7503 to enable telnet on a machine, then you can open a command prompt. Type the following 2 lines in the command prompt window.

    telnet push.active911.com 5222
    <stream:stream to="gmail.com" xml:lang="en" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client">

    If the port is blocked, you probably won't get far enough to enter the second line.

    If the port is not blocked, then you should receive something back like:
    <?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='857439991' from='push.active911.com' xml:lang='en'><stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'></host-unknown></stream:error></stream:stream>Connection closed by foreign host.

  • I did what you said above and got this message


                                                    <?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='3355278422' from='push.active911.com' xml:lang='en'><stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'></host-unknown></stream:error></stream:stream>

    Connection to host lost.

    so looks the same but the last part


    C:\Users\terry>
  • When clicking on incident map centers on Atlantic Ocean and not on the incident marker.
  • @Mathew A.
    Thanks for doing that for me. It looks like the necessary port is open so something else must be preventing the app from either receiving the alerts or displaying them appropriately once they come in.
    I'd like to start out by trying to verify that the alerts are actually being received correctly.
    In the menu bar you can select View and then Overview in the submenu. Click View -> Overview five times within five seconds. This will enable a Debug option in the menu bar. Open the logging window from the debug options.
    This will open a window that will log information as the app is running. You can then either wait for an alert to happen or you can send a test alert.
    If your app receives the alert, you should see a line that looks like the following show up.

    message:764396022:60139211:silent.caf:ALERT

    There may be a lot of text show up in the logging window. If you would like to copy the entire contents and email it to windowsbeta@active911.com, then I can interpret it for you. 

    I'm investigating this issue. Do the incidents you are selecting have a latitude and longitude associated with them or is it displaying 0,0 for the coordinate? Does your PC have an accurate GPS position? If your PC thinks it is very far away from the incident, the app will try to zoom out to show both your position and the incident's location. I'm just trying to narrow down where something is acting incorrectly, but it could be that the app is trying to fit the incident location and an invalid GPS location such as 0,0 into the map's view.
  • Suggestions:

    1.) Ruler should be in feet not miles
    2.) When you hit the X to get out of a call it should clear the map of routing. 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion