No alerts while phone inactive
  • Starting this evening, Alerts have not been coming through until I wake my phone.
    Had this happen twice.  As soon as phone wakes up, even before unlocking
    the alert comes through.
  • Make sure you don't have a battery saver enabled that turns your data off while phone sleeps. That will cause that behavior. Active911 needs some kind of data, or wifi to receive alerts, not just the cell service.
  • I'm having a similar issue.  Using the Active911 app, alerts come through several minutes late unless I manually wake the phone when we are getting a call via the station alarm.  In that case, it alerts immediately.  It acts like my phone is asleep then wakes every few minutes to see if there's any activity to report.

    Here's the interesting part:  if I revert to CadPage, and make no other changes to my phone, calls are always instant as they should be.  Somehow CadPage can wake the phone while Active911's app cannot.
  • I'm still seeing this behavior too, but It seems to only be happening when wifi is active.  When no wifi they seem to come through okay.
  • Make sure you don't have a firewall on the wifi system blocking it.
  • I've noticed that before, I think it was while I was connected to my companies WiFi, which is probably firewalled. As soon as I turned of the WiFi it started working.

    I don't know if it is an app thing or a phone thing but it would be nice if it would try to connect via WiFi and if it couldn't, try the cell data connection.
  • Ryan's comment about a possible firewall seems dead on.  Any differences in alerting between Cadpage and the Active911 app are probably either settings differences in your phone or (most likely) coincidence -- the alerting works the same way on both.  A good test is to see if your phone works better when in other wifi locations.  As Ryan said, it maybe that one or more of your wifi sources is firewalled.
  • John, unfortunately we cannot have our app connect to wifi first, and then data if that doesn't work. Some phones are designed to not connect to cell data if the wifi is connected. They do this to reduce data load on cell networks, but unfortunately firewalls can block the ports that APNs and GCM use. 

    According to Apple,

    "For APNs traffic to get past your firewall, you'll need to open these ports:
    • TCP port 5223 (used by devices to communicate to the APNs servers) 
    • TCP port 2195 (used to send notifications to the APNs)
    • TCP port 2196 (used by the APNs feedback service)
    • TCP Port 443 (used as a fallback on Wi-fi only, when devices are unable to communicate to APNs on port 5223)
    • The APNs servers use load balancing. Your devices will not always connect to the same public IP address for notifications. The entire 17.0.0.0/8 address block is assigned to Apple, so it's best to allow this range in your firewall settings."
    Active911, Inc
    support@active911.com
    https://www.active911.com/Contact